Netgear WPN802v2 – invalid security certificate

Using Firefox 3.0.x to connect to the Netgear Wireless Accesspoint WPN802v2, may fail due to an invalid security certificate error (see picture below):

Alert: <ip address> uses an ivalid security certificate

When this error occurs, you won’t be able to connect to the admin interface of the Wireless Accesspoint. I managed to fix this by creating a security exception in the Firefox Certificate Manager:

Select in ‘Tools‘ from the Menu bar, ‘Options’:

Select in the ‘Advanced’ tab – the ‘Encryption’ tab. Next, select ‘View Certificates‘.

In the Certificates Manager, select the ‘Servers’ tab. Next, select ‘Add Exception

Enter the IP Address of the Wireless Access Point in the ‘Add Security Exception’ window and select the ‘Get Certificate‘ button.

The Certificate Status will be displayed.

Select ‘Confirm Security Exception‘ and exit the Certificate Manager.

You should now be able to logon the Admin interface.

Print Friendly, PDF & Email